Directive Options Indexes ignorée par Apache 2.4

Si vous venez de passer à Apache 2.4, vous avez peut-être pu remarquer que les index automatiques du mod_autoindex ne fonctionnent plus.
Apache semble ignorer la directive Options +Indexes et retourne une erreur 403 Forbidden avec la ligne de log suivante :

Si vous utilisez fastcgi/php-fpm vous aurez à la place une erreur 404 File not found :

 

Apparemment, la version 2.4 de Apache nécessite la désactivation de DirectoryIndex pour avoir des index automatiques :

 

Leave a Reply

Your email address will not be published. Required fields are marked *